System - Incident

Major incident Supervisor Portal
2026-03-02 05:00 UTC · 3 hours, 28 minutes

Updates

Resolved

Dear Team Leaders,

Please be informed that the Supervisor Portal has been recovered. The following information is for your reference.

Quick Description:

  • User Impact: Users get error message when access to the Supervisor Portal page.
  • Root Cause: Case service down due to too many requests of case management report.

Time Window

  • Start Time: 2026-03-02 05:00 UTC (2026-03-02 13:00 UTC+8)
  • End Time: 2026-03-02 08:00 UTC (2026-03-02 16:00 UTC+8)

Actions Required:

  • Please forward the notification to relevant team members.
  • No other actions required from users at this time.

Contact Information: For further questions, please send ticket via Help Center.

We apologize for the service disruptions. Thank you for your patience and cooperation.

March 2, 2026 · 08:25 UTC
Update

Dear Team Leaders,

This is an update on the ongoing issue with Supervisor Portal. The following information is for your reference.

Current status:

  • Root Cause: Case service down due to too many requests of case management report.
  • Estimated Resolution Time: Unknown

Actions Suggested: Please try to run Case Management report at idle time such as lunch time or after 6PM China Time. If want to run report during working time, please try to narrow down the time frame as much as possible. And please do not click the “Export to Excel” button repeatedly. During outage time, if the system generated any incorrect data, please amend it from your side if you can.

Contact Information: For further questions please send ticket via Help Center.

The Software engineering team continues to work diligently to resolve the issue. We will provide further updates as soon as possible.

Thank you for your patience and understanding.

March 2, 2026 · 06:53 UTC
Issue

Dear Team Leaders,

Please be informed that Supervisor Portal is experiencing issues, which may result in performance degradation. The Tech team is urgently addressing the issue. The following information is for your reference.

Quick Description:

  • User Impact: Users get error message when access to the Supervisor Portal page.
  • Root Cause: Case service down due to too many requests of case management report.

Actions Required:

  • Please forward the notification to relevant team members.
  • No other actions required from users at this time.

Contact Information: For further questions please send ticket via Help Center.

We apologize for the service disruptions and will provide an update within the next hour.
Thank you for your patience and cooperation.

March 2, 2026 · 06:02 UTC

← Back