Technology System Maintenance and Update Notification - Completed from 2023-11-27 18:00 CST to 2023-12-08 10:45 CST

Scheduled maintenance Supervisor Portal
2023-11-27 18:00 CST · 1 week, 3 days, 16 hours, 45 minutes

Updates

Resolved

deal with status

December 8, 2023 · 10:45 CST
Update

Dear Leaders,

The system maintenance is completed and please update your Case Tracker to the latest version 1.0.5.176. Appreciate your patience during the time and feel free to send [email protected] for any questions.

November 22, 2023 · 17:15 CST

← Back